Kamis, 05 April 2012

Konfigurasi Static dan Dinamic Routing (Menggunakan Protokol EIGRP) Pada Router Cisco

Cisco, siapa yang tidak kenal nama ini, apa lagi orang yang bergelut di bidang IT. Cisco adalah sebuah perusahaan yang bergerak di bidang IT khususnya adalah hardware, walaupun sekarang sudah banyak mengeluarkan software. Produk unggulan dari Cisco sendri adalah router. Router Cisco terkenal handal dan stabil serta tahan lama. Banyak perusahaan besar yang menggunakan router ini untuk menghubungkan kantor-kantor cabangnya.
Routing sendiri adalah sebuah proses yang berguna untuk meneruskan paket-paket dari sebuah jaringan ke jaringan lainnya, dan biasanya routing ini dilakukan dengan menggunakan router. Pada tulisan ini saya tidak akan membahas tentang kelebihan dan kekurangan dari router Cisco, namun saya akan membahas bagaimana cara melakukan static routing dan dinamic routing dalam router Cisco, di mana untuk dinamic routing saya akan menggunakan protokol EIGRP (EIGRP akan dijelaskan nanti). Namun sebelum saya menjelaskan bagaimana melakukan konfigurasi static dan dinamic routing pada router Cisco ada baiknya saya sedikit memaparkan pengertian static dan dinamic routing serta kelebihan dan kekurangannya.
  1. Static routing adalah di mana seorang administrator melakukan routing secara manual. Mendefenisikan setiap network yang akan dihubungkan pada router-router yang akan digunakan.
  2. Dinamic routing adalah dimana administrator hanya melakukan sedikit konfigurasi (bisa dikatakan hanya mengaktifkan rule dinamic routing) pada setiap router yang akan dikomunikasikan, dan untuk kemudian router-router tersebut otomatis akan mendefenisikan network-network yang terhubung.
Beberapa kelebihan dan kekurangan dari static dan dinamic routing adalah sebagai berikut.
  1. Konfigurasi static routing memiliki kompleksitas yang bergantung pada jumlah network yang terhubung, sedangkan dinamic routing tidak, baik besar maupun kecil jumlah network yang akan dihubungkan, konfigurasi pada dinamic routing tetap sederhana.
  2. Jika terjadi pengubahan topologi, maka konfigurasi pada static routing (routing table) harus ditambah, dikurangi atau bahkan harus diubah keseluruhan, sedangkan pada dinamic routing tidak perlu adanya pengubahan pada konfigurasi routing (routing table).
  3. Static routing biasa digunakan pada jaringan dengan skala menengah kebawah, sedangkan dinamic routing biasa digunakan untuk jaringan sekala besar.
  4. Static routing memiliki tingkat keamanan yang baik, sedangkan dinamic routing tidak, karena jika ada seseorang yang menambakan sebuah router di dalam jaringan tersebut, maka router tersebut akan bisa langsung terkoneksi, dan hal itu bisa berbahaya.
  5. Static routing menggunakan sumber daya yang sedikit, baik itu processor, memori, maupun bandwidth, sedangkan dinamic routing menggunakan sumber daya lebih banyak.
Setelah mengerti pengertian, kelebihan dan kekurangan dari static dan dinamic routing, berikutnya akan saya paparkan contoh penerapan dari static dan dinamic routing menggunakan router Cisco. Pada tutorial ini saya menggunakan software Packet Tracert versi 5.3.0.0088.
Klik untuk memperbesar
Diatas terlihat sebuah simulasi jaringan antar kota yang menggunakan router untuk menghubungkan setiap kota. Pada router Medan dan Bali saya menambahkan sebuah modul yang bernama WIC-1T. WIC-1T adalah modul yang dipasangkan pada router Cisco yang digunakan sebagai port serial, sedangkan pada router Jakarta saya menambahkan 2 buah modul WIC-1T, karena router ini berada ditengah-tengah sehingga dibutuhkan 2 buah WIC-1T untuk menghubungkan 2 router lainnya. Berikut ini adalah konfigurasi dasar sebelum routing ditambahkan, baik static atau dinamic pada masing-masing router:
Router Medan:
Router>enable
Router#configure terminal
Router(config)#hostname MEDAN
MEDAN(config)#interface fastEthernet 0/0
MEDAN(config-if)#description TO-LAN
MEDAN(config-if)#ip address 192.168.1.254 255.255.255.0
MEDAN(config-if)#no shutdown
MEDAN(config-if)#exit
MEDAN(config)#interface serial 0/0/0
MEDAN(config-if)#description TO-JAKARTA
MEDAN(config-if)#ip address 10.10.1.1 255.255.255.252
MEDAN(config-if)#clock rate 64000
MEDAN(config-if)#no shutdown
MEDAN(config-if)#exit
MEDAN(config)#exit
MEDAN#copy running-config startup-config
Router Jakarta
Router>enable
Router#configure terminal
Router(config)#hostname JAKARTA
JAKARTA(config)#interface fastEthernet 0/0
JAKARTA(config-if)#description TO-LAN
JAKARTA(config-if)#ip address 192.168.2.254 255.255.255.0
JAKARTA(config-if)#no shutdown
JAKARTA(config-if)#exit
JAKARTA(config)#interface serial 0/0/0
JAKARTA(config-if)#description TO-MEDAN
JAKARTA(config-if)#ip address 10.10.1.2 255.255.255.252
JAKARTA(config-if)#clock rate 64000
JAKARTA(config-if)#no shutdown
JAKARTA(config-if)#exit
JAKARTA(config)#interface serial 0/1/0
JAKARTA(config-if)#description TO-BALI
JAKARTA(config-if)#ip address 11.11.1.1 255.255.255.252
JAKARTA(config-if)#clock rate 64000
JAKARTA(config-if)#no shutdown
JAKARTA(config-if)#exit
JAKARTA(config)#exit
JAKARTA#copy running-config startup-config
Router Bali
Router>enable
Router#configure terminal
Router(config)#hostname BALI
BALI(config)#interface fastEthernet 0/0
BALI(config-if)#description TO-LAN
BALI(config-if)#ip address 192.168.3.254 255.255.255.0
BALI(config-if)#no shutdown
BALI(config-if)#exit
BALI(config)#interface serial 0/0/0
BALI(config-if)#description TO-JAKARTA
BALI(config-if)#ip address 11.11.1.2 255.255.255.252
BALI(config-if)#clock rate 64000
BALI(config-if)#no shutdown
BALI(config-if)#exit
BALI(config)#exit
BALI#copy running-config startup-config
Dengan konfigurasi diatas koneksi yang terjadi adalah sebagai berikut:
  1. Router Medan dapat berkomunikasi dengan router Jakarta
  2. Router Jakarta dapat berkomunikasi dengan router Bali
  3. Router Medan tidak dapat berkomunikasi dengan router Bali
  4. LAN Medan tidak dapat berkomunikasi dengan LAN Jakarta
  5. LAN Jakarta tidak dapat berkomunikasi dengan LAN Bali
  6. LAN Medan tidak dapat berkomunikasi dengan LAN Bali
Agar semua node bisa saling berkomunikasi maka dilakukanlah routing. Berikut adalah routing dari masing-masing router menggunakan static dan dinamic routing. Untuk menambahkan routingan (routing table), administrator harus masuk ke mode globar configuration nama-router(config)# dengan mengetikkan:
Router>enable
Router#configure terminal
Router(config)#
.
1. STATIC SROUTING
1.1   Router Medan
MEDAN>enable
MEDAN#configure terinal
MEDAN(config)#ip route 192.168.2.0 255.255.255.0 serial 0/0/0
MEDAN(config)#ip route 11.11.1.0 255.255.255.252 serial 0/0/0
MEDAN(config)#ip route 192.168.3.0 255.255.255.0 serial 0/0/0
Penjelasan:
MEDAN(config)#ip route 192.168.2.0 255.255.255.0 serial 0/0/0
Routing di atas digunakan agar:
  1. Router Medan bisa berkomunikasi dengan LAN Jakarta.
  2. LAN Medan bisa berkomunikasi dengan LAN Jakarta.
MEDAN(config)#ip route 11.11.1.0 255.255.255.252 serial 0/0/0
Routing di atas digunakan agar:
  1. Router Medan bisa berkomunikasi dengan router Bali
  2. LAN Medan bisa berkomunikasi dengan router Bali
MEDAN(config)#ip route 192.168.3.0 255.255.255.0 serial 0/0/0
Routing di atas digunakan agar:
  1. Router Medan bisa berkomunikasi dengan LAN Bali.
  2. LAN Medan bisa berkomunikasi dengan router Bali
1.2   Router Jakarta
JAKARTA(config)#ip route 192.168.1.0 255.255.255.0 serial 0/0/0
Routing di atas digunakan agar:
  1. Router Jakarta bisa berkomunikasi dengan LAN Medan.
  2. LAN Jakarta bisa berkomunikasi dengan LAN Medan.
JAKARTA(config)#ip route 192.168.3.0 255.255.255.0 serial 0/1/0
Routing di atas digunakan agar:
  1. Router Jakarta bisa berkomunikasi dengan LAN Bali.
  2. LAN Jakarta bisa berkomunikasi dengan LAN Bali.
1.3   Router Bali
BALI(config)#ip route 192.168.1.0 255.255.255.0 serial 0/0/0
Routing di atas digunakan agar:
  1. Router Bali bisa berkomunikasi dengan LAN Medan.
  2. LAN Bali bisa berkomunikasi dengan LAN Medan.
BALI(config)#ip route 10.10.1.0 255.255.255.252 serial 0/0/0
Routing di atas digunakan agar:
  1. Router Bali bisa berkomunikasi dengan router Medan.
  2. LAN Bali bisa berkomunikasi dengan router Medan
BALI(config)#ip route 192.168.2.0 255.255.255.0 serial 0/0/0
Routing di atas digunakan agar:
  1. Router Bali bisa berkomunikasi dengan LAN Jakarta.
  2. LAN Bali bisa berkomunikasi dengan LAN Jakarta.
Ingat, pada 1 router hanya bisa mendefenisikan jalan untuk paket keluar, namun jalan untuk paket masuk tidak bisa. Misalnya, melakukan ping dari LAN Medan ke LAN Jakarta, jika hanya pada router Medan yang dilakukan routing agar bisa menuju LAN Jakarta, ping tidak akan pernah berhasil, karena pada router Jakarta routing untuk menuju LAN Medan tidak ada, jadi paket tidak akan pernah dikirim kembali ke LAN Medan, sehingga ping akan RTO (Request Time Out). Itulah mengapa pada router Medan ada routing yang bertujuan untuk mengenalkan LAN Jakarta, dan begitu juga router Jakarta terdapat routing yang bertujuan untuk mengenalkan LAN Medan, itu dilakukan agar paket bisa pergi dan bisa pulang.
2. ROUTING DINAMIC MENGGUNAKAN PROTOKOL EIGRP
Seperti yang sudah dijelaskan di atas bahwa routing dinamic bermanfaat untuk jaringan dengan skala besar, dimana routing dinamic bisa membuat kerja administrator menjadi sangat ringan. Walaupun biasanya digunakan dalam skala besar, namun bukan berarti routing dinamic tidak bisa digunakan dalam network skala kecil.
EIGRP (Enhanced Interior Gateway Routing Protokol) adalah salah satu protokol routing yang hanya bisa digunakan di router keluaran Cisco. Dimana protokol routing ini salah satu routing protocol terbaik yang memiliki ciri-ciri sebagai berikut:
  1. EIGRP hanya bisa digunakan pada router Cisco.
  2. EIGRP adalah lanjutan dari protkol IGRP.
  3. EIGRP adalah protokol routing dengan sifat Link State, dimana akan melakukan update apabila terdapat perubahan pada topologi jaringan yang mempengaruhi routing table.
  4. Maksimum hop pada EIGRP adalah 250, hop lebih banyak dari RIP yang hanya bisa menampung 15 hop.
  5. EIGRP menggunakan Autonomous System (AS). AS number Adalah nomor identifikasi yang menyatakan bahwa beberapa router berada dalam satu ruang lingkup yang sama sehingga akan bisa melakukan komunikasi. Jika AS number ini berbeda pada router satu dengan yang lainnya, maka router-router tersebut tidak akan bisa berkomunikasi.
  6. EIGRP mendukung VLSM (Variable Lenght Subnet Mask).
Untuk contoh konfigurasinya masih menggunakan contoh pada gambar di atas dimana konfigurasi dasarnya juga sama. berikut ini adalah konfigurasi dari EIGRP pada masing-masing router:
Klik untuk memperbesar
2.1 Router Medan
MEDAN>enable
MEDAN#configure terminal
MEDAN(config)#router eigrp 100
MEDAN(config-router)#network 192.168.1.0
MEDAN(config-router)#network 10.10.1.0
MEDAN(config-router)#exit
MEDAN(config)#exit
MEDAN#copy running-config startup-config
2.2 Router Jakarta
JAKARTA>enable
JAKARTA#configure terminal
JAKARTA(config)#router eigrp 100
JAKARTA(config-router)#network 192.168.2.0
JAKARTA(config-router)#network 10.10.1.0
JAKARTA(config-router)#network 11.11.1.0
JAKARTA(config-router)#exit
JAKARTA(config)#exit
JAKARTA#copy running-config startup-config
2.3 Router Bali
BALI>enable
BALI#configure terminal
BALI(config)#router eigrp 100
BALI(config-router)#network 192.168.3.0
BALI(config-router)#network 11.11.1.0
BALI(config-router)#exit
BALI(config)#exit
BALI#copy running-config startup-config
Bisa kita lihat di atas bahwa saya menggunakan 100 sebagai Autonomous System (AS) atau AS number. AS number ini bebas mau menggunakan berapa saja, yang penting sama antara satu router dengan router lainnya. Namun, jika sudah harus menghubungkan antara router di sebuah negara dengan router di negara lainnya, AS number ini tidak bisa digunakan sembarangan, ada sebuah badan yang mengurusnya, jadi kita harus menyewa AS number ini layaknya sebuah IP public.
Sampai di sini dulu sedikit penjelasan tentang static dan dinamic routing serta cara konfigurasinya, dimana pada dinamic routing saya menggunakan routing protokol EIGRP. Semoga tulisan saya ini bisa membantu bagi Anda yang sedang mempelajari routing, baik static maupun dinamic.

0 komentar :

Poskan Komentar

--=SILAHKAN BERKOMENTAR=--

Berikan Saran Dan Pendapat Sobat, Syukur - Syukur sobat mau menjadi FOLLOWERS blog ini, HEHEHEHEEE...
Saya Mohon Maaf Bila Dalam Penulisan Artikel Diatas Ada Kalimat atau Kata Yang Salah.. (<> , <>)

JANGAN BERKOMENTAR SPAM .!!!!

TERIMAH KASIH